Brad Wardell's views about technology, politics, religion, world affairs, and all sorts of politically incorrect topics.
Performance
Published on October 18, 2003 By Draginol In Misc
Right now JoeUser just strikes me as being really slow. At first, I thought it was all the database stuff. But now, the home page is done at an HTM and it's still slow for me. The Joeuser header bar at the top shows up and sometimes it stalls on me there and I have to hit refresh.

Seems CSS may not be so wonderful after all.

Is anyone else running into this?
Comments
on Oct 18, 2003
It actually doesn't load slowly, the render time just looks like it takes a long time due to the way you've nested all of your tables.

Your first table that includes your top logo area is simple and fast - you have image placeholders and such, so it loads up fast. However your second table contains all of the posts, all of the right rail, and any of the footer content.

The best way to handle it would be to lessen the nesting of tables.
on Oct 18, 2003
Are you using dialup?
Loads reasonably quickly on my DSL.
Nothing to brag about...but neither is it anything to complain about on my end.
on Oct 18, 2003
Due to how new CSS is and the low support from browsers at the moment, when rendering CSS browsers seem to use less memory to render CSS compared to the amount of memory used to render tables correctly. This may sound like a good thing but with a fast PC and a fast connection, Web pages appear to load slowly compared to other Web pages with a table design.

Mozilla Firebird 0.7 has just been released which runs CSS rendering in real time, meaning faster computers can use more memory to render pages more faster so they appear quicker. This co-insides with the better support that has been added to allow more functionality with CSS.
on Oct 18, 2003
It has been fast for me, but I have cable and a fast system. The only problem I have run into is that sometimes the "comments" pages won't load. I will get a message that essentially says the what I am trying to access doesn't exist
on Oct 18, 2003
I just tried Mozilla and it is indeed much better with that than with IE. Which is ironic.
on Oct 19, 2003
yeah, joeuser definitely has a pause period after the header bar even on my cable connection.
on Oct 19, 2003
The comments pages not loading seems to be a bug only when viewing from the channel indexes.
Meta
Views
» 2450
Comments
» 7
Category
» Misc
Sponsored Links